Intellij IDEA无法使用lombok解决方法

添加Maven依赖

在项目的pom文件的dependency标签内加上:

<!-- https://mvnrepository.com/artifact/org.projectlombok/lombok -->
<dependency>
    <groupId>org.projectlombok</groupId>
    <artifactId>lombok</artifactId>
    <version>1.16.18</version>
    <scope>provided</scope>
</dependency>

@Data用法

大家可以参考我的另外一篇文章《【lombok】@Data》,其实用法还比较简单。@Data可以替代Setter和Getter,省去许多时间。

不使用@Data

public class Person{
	private String name;
	private String age;
	private String sex;
	
	public String getName() {
        return name;
    }

    public void setName(String name) {
        this.name= name;
    }
	// 其他字段省略
	...
	
}

使用@Data

import lombok.Data;
@Data
public class Person{
	private String name;
	private String age;
	private String sex;
}

但是呢?new一个Person类,再调用person setName()方法,setAge()或者setSex()时竟然会显示红色。表示@Data并没有生效。

重点

步骤:

  1. File - > setting - > plugins
  2. 点击Browse Repositories输入lombok
  3. 点击安装
  4. 重启IDEA

update

  1. 如果你的 idea 太老,虽然安装了 lombok 也不一定生效,lombok 版本不一定会向后兼容,建议安装 19 年 20 年的版本
相关推荐
©️2020 CSDN 皮肤主题: 撸撸猫 设计师:马嘣嘣 返回首页